キャストのスタイル

JavaC#でキャストをどう書くのがいいんだろう?
今までは何のためらいもなく閉じカッコの後に空白を置いていたんだけど、キャストも単項演算子*1であると言うことを考えると・・・

int i = +1;
int j = -1;
int k = ~j;
++i;
--j;
boolean b = !(i == j);

こうなるよなー。

double d = (double)i;


うーん、C++なら何も問題ないのに。

double d = static_cast<double>(i);

*1:型名は項に数えないっぽい