読者です 読者をやめる 読者になる 読者になる

部分文字列

Program

部分文字列って分かりにくくない?
第一引数はいいとして、第二引数は言語によって、インデックスを指定したり長さを指定したり、その両方が使えたり*1


どういう名前なら分かりやすいだろう?
substringByIndex, substringByLengthとか?


あー、Pythonライクなキーワード引数さえあればいいんだよな。


現状ではラッパ関数書くのが現実的かも。
それを考えると拡張メソッドも素敵。
マップでキーワード引数っぽいのを実現しようとしても、結局ラッパ関数書かざるを得ないんだし。

*1:関数が分かれてる